<!DOCTYPE html><html lang=en-US><head><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1"><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Rubik:300,400,500,700,900,300italic,400italic,500italic,700italic,900italic"] },classes:false, events:false, timeout:1500};</script><link rel=profile href="https://gmpg.org/xfn/11"><link rel=pingback href=https://thegeekherald.com/xmlrpc.php><link media=all href=//cdn.thegeekherald.com/wp-content/cache/autoptimize/css/autoptimize_fe5ffe3a3166e6242545e884b0ae2415.css rel=stylesheet><title>Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date - The Geek Herald</title> <script>var ajaxurl = "https://thegeekherald.com/wp-admin/admin-ajax.php"</script> <meta name=robots content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link rel=canonical href=https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date - The Geek Herald"><meta property=og:description content="Matrix 4 leaked videos are coming out recently as the main cast has started filming on outdoor locations. Keanu Reeves as Neo and Carrie-Anne Moss as Trinity are back for more action sequences and can be seen chased by several agents in one of the leaked set videos. It also gives out huge Matrix 4 plot spoilers hinting the fate of Neo and other story details. Here is the full description of Matrix 4 set video and how it reveals plot spoilers for Neo and the Agents in the movie. Matrix 4 Leaked Set Video Descriptions Matrix 4 is filming &hellip;"><meta property=og:url content=https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/><meta property=og:site_name content="The Geek Herald"><meta property=article:tag content=Agent><meta property=article:tag content="Keanu Reeves"><meta property=article:tag content=leaks><meta property=article:tag content="Matrix 4"><meta property=article:tag content=Neo><meta property=article:tag content="release date"><meta property=article:tag content=spoilers><meta property=article:tag content=theories><meta property=article:section content=Entertainment><meta property=article:published_time content=2020-03-08T19:48:47+00:00><meta property=og:image content=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-1024x576.jpg><meta property=og:image:secure_url content=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-1024x576.jpg><meta property=og:image:width content=1024><meta property=og:image:height content=576><meta name=twitter:card content=summary_large_image><meta name=twitter:description content="Matrix 4 leaked videos are coming out recently as the main cast has started filming on outdoor locations. Keanu Reeves as Neo and Carrie-Anne Moss as Trinity are back for more action sequences and can be seen chased by several agents in one of the leaked set videos. It also gives out huge Matrix 4 plot spoilers hinting the fate of Neo and other story details. Here is the full description of Matrix 4 set video and how it reveals plot spoilers for Neo and the Agents in the movie. Matrix 4 Leaked Set Video Descriptions Matrix 4 is filming [&hellip;]"><meta name=twitter:title content="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date - The Geek Herald"><meta name=twitter:image content=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-scaled.jpg> <script type=application/ld+json class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://thegeekherald.com/#organization","name":"The Geek Herald","url":"https://thegeekherald.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://thegeekherald.com/#logo","url":"https://cdn.thegeekherald.com/wp-content/uploads/2019/06/Copy-of-Copy-of-The-Geek-Herald.png","width":70,"height":60,"caption":"The Geek Herald"},"image":{"@id":"https://thegeekherald.com/#logo"}},{"@type":"WebSite","@id":"https://thegeekherald.com/#website","url":"https://thegeekherald.com/","name":"The Geek Herald","description":"#1 Geek News Portal","publisher":{"@id":"https://thegeekherald.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://thegeekherald.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#primaryimage","url":"https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-scaled.jpg","width":2560,"height":1440,"caption":"Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date"},{"@type":"WebPage","@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#webpage","url":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/","inLanguage":"en-US","name":"Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date - The Geek Herald","isPartOf":{"@id":"https://thegeekherald.com/#website"},"primaryImageOfPage":{"@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#primaryimage"},"datePublished":"2020-03-08T19:48:47+00:00","dateModified":"2020-03-08T19:48:47+00:00"},{"@type":"Article","@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#article","isPartOf":{"@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#webpage"},"author":{"@id":"https://thegeekherald.com/#/schema/person/ca42581fa44eab174ae353164f0e48f3"},"headline":"Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date","datePublished":"2020-03-08T19:48:47+00:00","dateModified":"2020-03-08T19:48:47+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#webpage"},"publisher":{"@id":"https://thegeekherald.com/#organization"},"image":{"@id":"https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/#primaryimage"},"keywords":"Agent,Keanu Reeves,leaks,Matrix 4,Neo,release date,spoilers,theories","articleSection":"Entertainment,News"},{"@type":["Person"],"@id":"https://thegeekherald.com/#/schema/person/ca42581fa44eab174ae353164f0e48f3","name":"Taylor","sameAs":[]}]}</script> <link rel=amphtml href=https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/amp/><meta name=generator content="AMP for WP 1.0.14"><link href=https://fonts.gstatic.com crossorigin=anonymous rel=preconnect><link href=https://ajax.googleapis.com rel=preconnect><link href=https://fonts.googleapis.com rel=preconnect><link rel=alternate type=application/rss+xml title="The Geek Herald &raquo; Feed" href=https://thegeekherald.com/feed/><link rel=stylesheet id=a3a3_lazy_load-css href=https://cdn.thegeekherald.com/wp-content/uploads/sass/a3_lazy_load.min.css type=text/css media=all> <script src=https://cdn.thegeekherald.com/wp-includes/js/jquery/jquery.x55335.js></script> <link rel=https://api.w.org/ href=https://thegeekherald.com/wp-json/><link rel=EditURI type=application/rsd+xml title=RSD href=https://thegeekherald.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://cdn.thegeekherald.com/wp-includes/wlwmanifest.xml><link rel=shortlink href='https://thegeekherald.com/?p=19431'><link rel=alternate type=application/json+oembed href="https://thegeekherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><link rel=alternate type=text/xml+oembed href="https://thegeekherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F&#038;format=xml"> <script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/thegeekherald.com\/p\/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date\/"},"url":"https:\/\/thegeekherald.com\/p\/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date\/","headline":"Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release...","datePublished":"2020-03-08T19:48:47+00:00","dateModified":"2020-03-08T19:48:47+00:00","publisher":{"@type":"Organization","@id":"https:\/\/thegeekherald.com\/#organization","name":"The Geek Herald","logo":{"@type":"ImageObject","url":"https:\/\/cdn.thegeekherald.com\/wp-content\/uploads\/2019\/06\/Copy-of-Copy-of-The-Geek-Herald.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/thegeekherald.com\/wp-content\/uploads\/2020\/03\/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-scaled.jpg","width":2560,"height":1440},"articleSection":"Entertainment","description":"Matrix 4 leaked videos are coming out recently as the main cast has started filming on outdoor locations. Keanu Reeves as Neo and Carrie-Anne Moss as Trinity are back for more action sequences and can be seen chased by several agents in one of the leaked set videos. It","author":{"@type":"Person","name":"Taylor","url":"https:\/\/thegeekherald.com\/p\/author\/taylor\/","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/d75ab2cb7283543bca37ba6c47e5456a?s=96&d=mm&r=g","height":96,"width":96}},"video":[null,null,null,null,null]}</script> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-18309869-35"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-18309869-35');</script> <script type=application/ld+json>{
    "@context": "http://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https://thegeekherald.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/",
                "name": "Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date",
                "image": "https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-scaled.jpg"
            }
        }
    ]
}</script> <link rel=icon href=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-150x150.png sizes=32x32><link rel=icon href=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-300x300.png sizes=192x192><link rel=apple-touch-icon-precomposed href=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-180x180.png><meta name=msapplication-TileImage content=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-300x300.png><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-19431 single-format-standard header-1"><div class=site-wrapper><header class=site-header><div class="header-main hidden-xs hidden-sm"><div class=container><div class="row row--flex row--vertical-center"><div class=col-xs-3><div class=header-social><ul class="social-list social-list--lg list-horizontal"></ul></div></div><div class=col-xs-6><div class="header-logo text-center">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo width=200px>
</a></div></div><div class="col-xs-3 text-right"></div></div></div></div><div id=mnmd-mobile-header class="mobile-header visible-xs visible-sm "><div class="mobile-header__inner mobile-header__inner--flex"><div class="header-branding header-branding--mobile mobile-header__section text-left"><div class="header-logo header-logo--mobile flexbox__item text-left">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></div></div><div class="mobile-header__section text-right">
<button type=submit class="mobile-header-btn js-search-dropdown-toggle">
<span class=hidden-xs>Search</span><i class="mdicon mdicon-search mdicon--last hidden-xs"></i><i class="mdicon mdicon-search visible-xs-inline-block"></i>
</button>
<a href=#mnmd-offcanvas-mobile class="offcanvas-menu-toggle mobile-header-btn js-mnmd-offcanvas-toggle">
<span class=hidden-xs>Menu</span><i class="mdicon mdicon-menu mdicon--last hidden-xs"></i><i class="mdicon mdicon-menu visible-xs-inline-block"></i>
</a></div></div></div><nav class="navigation-bar hidden-xs hidden-sm js-sticky-header-holder"><div class=container><div class=navigation-bar__inner><div class="navigation-bar__section hidden-xs hidden-sm">
<a href=#mnmd-offcanvas-primary class="offcanvas-menu-toggle navigation-bar-btn js-mnmd-offcanvas-toggle"><i class="mdicon mdicon-menu"></i></a></div><div class="navigation-wrapper navigation-bar__section js-priority-nav"><div id=main-menu class=menu-main-menu-container><ul id=menu-main-menu class="navigation navigation--main navigation--inline"><li id=menu-item-141 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li id=menu-item-142 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li id=menu-item-143 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li id=menu-item-144 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li id=menu-item-145 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div><div class="navigation-bar__section lwa lwa-template-modal">
<button type=submit class="navigation-bar-btn js-search-dropdown-toggle"><i class="mdicon mdicon-search"></i></button></div></div><div id=header-search-dropdown class="header-search-dropdown ajax-search is-in-navbar js-ajax-search"><div class="container container--narrow"><form class="search-form search-form--horizontal" method=get action=https://thegeekherald.com/><div class=search-form__input-wrap>
<input type=text name=s class=search-form__input placeholder=Search value></div><div class=search-form__submit-wrap>
<button type=submit class="search-form__submit btn btn-primary">Search</button></div></form><div class=search-results><div class=typing-loader></div><div class=search-results__inner></div></div></div></div></div></nav></header><div class="quads-location quads-ad4" id=quads-ad4 style="float:none;margin:10px 0px 0px 0px;text-align:center;"> <script async data-cfasync=false src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script><script data-cfasync=false>var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class=adsbygoogle style=display:inline-block;width:970px;height:90px; data-ad-client=pub-5748521297210733 data-ad-slot=6014974082 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class=adsbygoogle style=display:inline-block;width:728px;height:90px; data-ad-client=pub-5748521297210733 data-ad-slot=6014974082 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class=adsbygoogle style=display:inline-block;width:728px;height:90px; data-ad-client=pub-5748521297210733 data-ad-slot=6014974082 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div><div class="site-content single-entry"><div class="mnmd-block mnmd-block--fullwidth single-entry-wrap"><div class=container><div class=row><div class="mnmd-main-col " role=main><article class="mnmd-block post--single post-19431 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-news tag-agent tag-keanu-reeves tag-leaks tag-matrix-4 tag-neo tag-release-date tag-spoilers tag-theories"><div class=single-content><header class=single-header>
<a class="cat-5 post__cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a><a class="cat-3 post__cat cat-theme" href=https://thegeekherald.com/p/category/news/>News</a><h1 class="entry-title">Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date</h1><div class=entry-meta>
<span class="entry-author entry-author--with-ava">
By <a class=entry-author__name title="Posts by Taylor" rel=author href=https://thegeekherald.com/p/author/taylor/>Taylor</a> </span>
<time class="time published" datetime=2020-03-08T19:48:47+00:00 title="March 8, 2020 at 7:48 pm"><i class="mdicon mdicon-schedule"></i>9 seconds ago</time></div></header><div class="entry-interaction entry-interaction--horizontal"><div class=entry-interaction__left><div class="post-sharing post-sharing--simple"><ul><li><a class="sharing-btn sharing-btn-primary facebook-btn facebook-theme-bg" data-toggle=tooltip data-placement=top title="Share on Facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><i class="mdicon mdicon-facebook"></i><span class=sharing-btn__text>Share</span></a></li><li><a class="sharing-btn sharing-btn-primary twitter-btn twitter-theme-bg" data-toggle=tooltip data-placement=top title="Share on Twitter" onClick="window.open('http://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F&amp;text=Matrix%204%20Huge%20Neo%20Plot%20Spoilers%20Leaked%20ahead%20of%20Release%20Date','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F&amp;text=Matrix%204%20Huge%20Neo%20Plot%20Spoilers%20Leaked%20ahead%20of%20Release%20Date"><i class="mdicon mdicon-twitter"></i><span class=sharing-btn__text>Tweet</span></a></li><li><a class="sharing-btn googleplus-btn googleplus-theme-bg" data-toggle=tooltip data-placement=top title="Share on Google+" onClick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><i class="mdicon mdicon-google-plus"></i></a></li><li><a class="sharing-btn pinterest-btn pinterest-theme-bg" data-toggle=tooltip data-placement=top title="Share on Pinterest" href="javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;http://assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());"><i class="mdicon mdicon-pinterest-p"></i></a></li><li><a class="sharing-btn linkedin-btn linkedin-theme-bg" data-toggle=tooltip data-placement=top title="Share on Linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><i class="mdicon mdicon-linkedin"></i></a></li></ul></div></div><div class=entry-interaction__right>
<a href=#comments class="comments-count entry-action-btn" data-toggle=tooltip data-placement=top title="0 Comments"><i class="mdicon mdicon-chat_bubble"></i><span>0</span></a></div></div><div class="entry-thumb single-entry-thumb"><img width=800 height=400 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-800x400.jpg class="lazy lazy-hidden attachment-tnm-m-2_1 size-tnm-m-2_1 wp-post-image" alt="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-800x400.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-400x200.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-600x300.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-1200x600.jpg 1200w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-1600x800.jpg 1600w" sizes="(max-width: 800px) 100vw, 800px"><noscript><img
width=800 height=400 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-800x400.jpg class="attachment-tnm-m-2_1 size-tnm-m-2_1 wp-post-image" alt="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-800x400.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-400x200.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-600x300.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-1200x600.jpg 1200w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-1600x800.jpg 1600w" sizes="(max-width: 800px) 100vw, 800px"></noscript></div><div class="single-body entry-content typography-copy"><div class="quads-location quads-ad1" id=quads-ad1 style="float:none;margin:3px 0 3px 0;text-align:center;"> <script async data-cfasync=false src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script><script data-cfasync=false>var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class=adsbygoogle style=display:inline-block;width:300px;height:250px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div><p>Matrix 4 leaked videos are coming out recently as the main cast has started filming on outdoor locations. Keanu Reeves as Neo and Carrie-Anne Moss as Trinity are back for more action sequences and can be seen chased by several agents in one of the leaked set videos. It also gives out huge Matrix 4 plot spoilers hinting the fate of Neo and other story details. Here is the full description of Matrix 4 set video and how it reveals plot spoilers for Neo and the Agents in the movie.</p><h3 style="text-align: center">Matrix 4 Leaked Set Video Descriptions</h3><p><img class="lazy lazy-hidden aligncenter size-full wp-image-19433" src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions.jpg alt="Matrix 4 Leaked Set Video Descriptions" width=1200 height=777 srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions.jpg 1200w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions-300x194.jpg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions-1024x663.jpg 1024w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions-768x497.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px"><noscript><img
class="aligncenter size-full wp-image-19433" src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions.jpg alt="Matrix 4 Leaked Set Video Descriptions" width=1200 height=777 srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions.jpg 1200w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions-300x194.jpg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions-1024x663.jpg 1024w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Leaked-Set-Video-Descriptions-768x497.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript></p><p>Matrix 4 is filming currently in San Francisco where a few videos have been leaked online from the production set and it shows a big action sequence. It can be seen that multiple Agents are chasing Neo and Trinity through the streets in rain, which reminds us of the famous Agent Smith (Hugo Weaving) and his duplication sequence. Neo and Trinity are running away on a bike where several agents are chasing them.</p><blockquote class=twitter-tweet data-width=550 data-dnt=true><p lang=en dir=ltr>Last night on my block filming Matrix 4 <a href="https://twitter.com/hashtag/matrix?src=hash&amp;ref_src=twsrc%5Etfw">#matrix</a> <a href="https://twitter.com/hashtag/Matrix?src=hash&amp;ref_src=twsrc%5Etfw">#Matrix</a> <a href="https://twitter.com/hashtag/matrix4?src=hash&amp;ref_src=twsrc%5Etfw">#matrix4</a> <a href="https://twitter.com/hashtag/Matrix4?src=hash&amp;ref_src=twsrc%5Etfw">#Matrix4</a> <a href="https://twitter.com/hashtag/MatrixHR?src=hash&amp;ref_src=twsrc%5Etfw">#MatrixHR</a> <a href="https://twitter.com/hashtag/matrix4sf?src=hash&amp;ref_src=twsrc%5Etfw">#matrix4sf</a> <a href="https://twitter.com/hashtag/projecticeceeam?src=hash&amp;ref_src=twsrc%5Etfw">#projecticeceeam</a> <a href="https://twitter.com/hashtag/matrixmovie?src=hash&amp;ref_src=twsrc%5Etfw">#matrixmovie</a> <a href="https://twitter.com/hashtag/behindthescenesmatrix4?src=hash&amp;ref_src=twsrc%5Etfw">#behindthescenesmatrix4</a> <a href="https://twitter.com/hashtag/keanureeves?src=hash&amp;ref_src=twsrc%5Etfw">#keanureeves</a> <a href="https://twitter.com/hashtag/Keanu?src=hash&amp;ref_src=twsrc%5Etfw">#Keanu</a> <a href="https://twitter.com/hashtag/sanfrancisco?src=hash&amp;ref_src=twsrc%5Etfw">#sanfrancisco</a> <a href="https://twitter.com/hashtag/moviemaking?src=hash&amp;ref_src=twsrc%5Etfw">#moviemaking</a> <a href=https://t.co/AOgBDW4H4D>pic.twitter.com/AOgBDW4H4D</a></p><p>&mdash; SkyBobbyTv (@SkyBobbyTv1) <a href="https://twitter.com/SkyBobbyTv1/status/1234370140013072384?ref_src=twsrc%5Etfw">March 2, 2020</a></p></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><blockquote class=twitter-tweet data-width=550 data-dnt=true><p lang=da dir=ltr>Matrix 4 filming in San Francisco <a href="https://twitter.com/hashtag/Matrix4?src=hash&amp;ref_src=twsrc%5Etfw">#Matrix4</a> <a href="https://twitter.com/hashtag/matrix?src=hash&amp;ref_src=twsrc%5Etfw">#matrix</a> <a href=https://t.co/4YbE8jkJ6u>pic.twitter.com/4YbE8jkJ6u</a></p><p>&mdash; SkyBobbyTv (@SkyBobbyTv1) <a href="https://twitter.com/SkyBobbyTv1/status/1234384646147674112?ref_src=twsrc%5Etfw">March 2, 2020</a></p><div class="quads-location quads-ad2" id=quads-ad2 style="float:none;margin:0px 0px 10px 0px;text-align:center;"> <script async data-cfasync=false src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script><script data-cfasync=false>var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class=adsbygoogle style=display:inline-block;width:300px;height:250px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script> </div></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><blockquote class=twitter-tweet data-width=550 data-dnt=true><p lang=en dir=ltr>Kiana Reaves doing a walk-through in front of my building Getting ready to do the motorcycle chase <a href="https://twitter.com/hashtag/Matrix4?src=hash&amp;ref_src=twsrc%5Etfw">#Matrix4</a> <a href="https://twitter.com/hashtag/matrix?src=hash&amp;ref_src=twsrc%5Etfw">#matrix</a> <a href="https://twitter.com/hashtag/keanureeves?src=hash&amp;ref_src=twsrc%5Etfw">#keanureeves</a> <a href=https://t.co/TVszDN7A4w>pic.twitter.com/TVszDN7A4w</a></p><p>&mdash; SkyBobbyTv (@SkyBobbyTv1) <a href="https://twitter.com/SkyBobbyTv1/status/1234376961805307904?ref_src=twsrc%5Etfw">March 2, 2020</a></p></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><blockquote class=twitter-tweet data-width=550 data-dnt=true><p lang=en dir=ltr>On the set of matrix and they set these cars on fire <a href="https://twitter.com/hashtag/Matrix4?src=hash&amp;ref_src=twsrc%5Etfw">#Matrix4</a> <a href="https://twitter.com/hashtag/matrix?src=hash&amp;ref_src=twsrc%5Etfw">#matrix</a> <a href=https://t.co/yDRvjFdd82>pic.twitter.com/yDRvjFdd82</a></p><p>&mdash; SkyBobbyTv (@SkyBobbyTv1) <a href="https://twitter.com/SkyBobbyTv1/status/1234468101665648642?ref_src=twsrc%5Etfw">March 2, 2020</a></p></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><p>There is another video where Keanu Reeves is seen walking through the streets to understand how to film the action sequence. It should be noted that Reeves is having long hairs similar to John Wick style, which hints that Neo will sport a different look in Matrix 4. The action sequence is very intense and several cars were burned by the production crew, which means that Matrix 4 will have a lot of big action scenes.</p><p>&nbsp;</p><h3 style="text-align: center">Matrix 4 Plot Spoilers and Theories</h3><p><img class="lazy lazy-hidden aligncenter size-full wp-image-19434" src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories-.png alt="Matrix 4 Plot Spoilers and Theories " width=1280 height=720 srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories-.png 1280w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--300x169.png 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--1024x576.png 1024w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--768x432.png 768w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--400x225.png 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--600x338.png 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--800x450.png 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--1200x675.png 1200w" sizes="(max-width: 1280px) 100vw, 1280px"><noscript><img
class="aligncenter size-full wp-image-19434" src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories-.png alt="Matrix 4 Plot Spoilers and Theories " width=1280 height=720 srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories-.png 1280w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--300x169.png 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--1024x576.png 1024w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--768x432.png 768w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--400x225.png 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--600x338.png 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--800x450.png 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Plot-Spoilers-and-Theories--1200x675.png 1200w" sizes="(max-width: 1280px) 100vw, 1280px"></noscript></p><p>Matrix 4 plot is currently kept as a secret but there are several theories out on the internet predicting the story of this sequel. One major theory says that Matrix 4 plot will be inspired by the books where Neo after becoming the One realizes that he will be needed in the future and hence uploads fragments of his avatar code in the machine so that he can come back in the system. <a href=https://thegeekherald.com/p/the-matrix-4-rumor-wachowskis-returning-to-direct-new-movie/>The Matrix 4 release date is set as May 21, 2021,</a> which is also the same date when John Wick 4 will come out in theaters.</p>
<iframe class="lazy lazy-hidden" id=fv_ytplayer_cc13eebb403efe57541cb4c1b3358899 type=text/html width=640 height=360 data-lazy-type=iframe data-src='//www.youtube.com/embed/xTvJt1uZoCc?autoplay=1&amp;origin=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F' frameborder=0 webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe><noscript><iframe
id=fv_ytplayer_cc13eebb403efe57541cb4c1b3358899 type=text/html width=640 height=360
src='//www.youtube.com/embed/xTvJt1uZoCc?autoplay=1&amp;origin=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F' frameborder=0 webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe></noscript></div><footer class="single-footer entry-footer"><div class=entry-info><div class="row row--space-between grid-gutter-10"><div class="entry-categories col-sm-6"><ul><li class=entry-categories__icon><i class="mdicon mdicon-folder"></i><span class=sr-only>Posted in</span></li><li><a class="cat-5 entry-cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li><a class="cat-3 entry-cat cat-theme" href=https://thegeekherald.com/p/category/news/>News</a></li></ul></div><div class="entry-tags col-sm-6"><ul><li class=entry-tags__icon><i class="mdicon mdicon-local_offer"></i><span class=sr-only>Tagged with</span></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/agent/>Agent</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/keanu-reeves/>Keanu Reeves</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/leaks/>leaks</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/matrix-4/>Matrix 4</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/neo/>Neo</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/release-date/>release date</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/spoilers/>spoilers</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/theories/>theories</a></li></ul></div></div></div><div class="entry-interaction entry-interaction--horizontal"><div class=entry-interaction__left><div class="post-sharing post-sharing--simple"><ul><li><a class="sharing-btn sharing-btn-primary facebook-btn facebook-theme-bg" data-toggle=tooltip data-placement=top title="Share on Facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><i class="mdicon mdicon-facebook"></i><span class=sharing-btn__text>Share</span></a></li><li><a class="sharing-btn sharing-btn-primary twitter-btn twitter-theme-bg" data-toggle=tooltip data-placement=top title="Share on Twitter" onClick="window.open('http://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F&amp;text=Matrix%204%20Huge%20Neo%20Plot%20Spoilers%20Leaked%20ahead%20of%20Release%20Date','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F&amp;text=Matrix%204%20Huge%20Neo%20Plot%20Spoilers%20Leaked%20ahead%20of%20Release%20Date"><i class="mdicon mdicon-twitter"></i><span class=sharing-btn__text>Tweet</span></a></li><li><a class="sharing-btn googleplus-btn googleplus-theme-bg" data-toggle=tooltip data-placement=top title="Share on Google+" onClick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><i class="mdicon mdicon-google-plus"></i></a></li><li><a class="sharing-btn pinterest-btn pinterest-theme-bg" data-toggle=tooltip data-placement=top title="Share on Pinterest" href="javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;http://assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());"><i class="mdicon mdicon-pinterest-p"></i></a></li><li><a class="sharing-btn linkedin-btn linkedin-theme-bg" data-toggle=tooltip data-placement=top title="Share on Linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fmatrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date%2F"><i class="mdicon mdicon-linkedin"></i></a></li></ul></div></div><div class=entry-interaction__right>
<a href=#comments class="comments-count entry-action-btn" data-toggle=tooltip data-placement=top title="0 Comments"><i class="mdicon mdicon-chat_bubble"></i><span>0</span></a></div></div></footer></div></article><div class="quads-location quads-ad6" id=quads-ad6 style="float:none;margin:3px 0 3px 0;text-align:center;"><div id=rcjsload_19e1f7></div> <script>revcontent = jQuery(window).scroll(function() {
	   var hT = jQuery('#rcjsload_19e1f7').offset().top,
	       hH = jQuery('#rcjsload_19e1f7').outerHeight(),
	       wH = jQuery(window).height(),
	       wS = jQuery(this).scrollTop();
     //load 1200px before
     //if (wS+2000 > (hT+hH-wH)){ 
       if(true) {
			(function() {
			var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
			var rcds = document.getElementById("rcjsload_19e1f7");
			var rcel = document.createElement("script");
			rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
			rcel.type = 'text/javascript';
			rcel.src = "//trends.revcontent.com/serve.js.php?w=112264&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+encodeURIComponent(referer);
			rcel.async = true;
			rcds.appendChild(rcel);
			})();       
            revcontent.unbind();
	   }
	});</script></div><div class="posts-navigation single-entry-section clearfix"><div class=posts-navigation__prev><article class="post--overlay post--overlay-bottom post--overlay-floorfade"><div class=background-img style="background-image: url('https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x225.jpg');"></div><div class="post__text inverse-text"><div class=post__text-wrap><div class=post__text-inner><h3 class="post__title typescale-1">Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers</h3></div></div></div><a href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/ class=link-overlay></a></article><a class=posts-navigation__label href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/><span><i class="mdicon mdicon-arrow_back"></i>Previous article</span></a></div></div><div class="related-posts single-entry-section"><div class="block-heading "><h4 class="block-heading__title">You may also like</h4></div><div class=posts-list><div class="posts-list list-space-xl"><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-5 post__cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/>Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/derick/>Derick Hawker</a></span><time class="time published" datetime=2020-03-08T19:29:18+00:00 title="March 8, 2020 at 7:29 pm"><i class="mdicon mdicon-schedule"></i>20 mins ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/coronavirus-survival-ratio-symptoms-treatment-and-everything-you-need-to-know/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-8427 post__cat cat-theme" href=https://thegeekherald.com/p/category/health/>Health</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/coronavirus-survival-ratio-symptoms-treatment-and-everything-you-need-to-know/>Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/chad/>Chad Hillston</a></span><time class="time published" datetime=2020-03-08T19:24:37+00:00 title="March 8, 2020 at 7:24 pm"><i class="mdicon mdicon-schedule"></i>24 mins ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/coronavirus-survival-ratio-symptoms-treatment-and-everything-you-need-to-know/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/rick-and-morty-season-4-episode-6-release-date-new-trailer-teases-part-two-of-fourth-season/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Rick and Morty Season 4 Episode 6 Release Date New Trailer teases Part Two of Fourth Season" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Rick and Morty Season 4 Episode 6 Release Date New Trailer teases Part Two of Fourth Season" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-5 post__cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/rick-and-morty-season-4-episode-6-release-date-new-trailer-teases-part-two-of-fourth-season/>Rick and Morty Season 4 Episode 6 Release Date: New Trailer teases Part Two of Fourth Season</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/becca/>Becca Hilston</a></span><time class="time published" datetime=2020-03-08T19:12:19+00:00 title="March 8, 2020 at 7:12 pm"><i class="mdicon mdicon-schedule"></i>37 mins ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/rick-and-morty-season-4-episode-6-release-date-new-trailer-teases-part-two-of-fourth-season/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div></div></div></div><div class="same-category-posts single-entry-section"><div class="block-heading "><h4 class="block-heading__title">More in <a href=https://thegeekherald.com/p/category/entertainment/ class="cat-5 cat-theme">Entertainment</a></h4></div><div class=posts-list><div class="posts-list list-space-xl"><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/black-adam-trailer-release-date-cast-plot-and-dwayne-rock-johnson-revealing-workout-details/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#039;Rock&#039; Johnson Revealing Workout Details" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#039;Rock&#039; Johnson Revealing Workout Details" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-5 post__cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/black-adam-trailer-release-date-cast-plot-and-dwayne-rock-johnson-revealing-workout-details/>Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#8216;Rock&#8217; Johnson Revealing Workout Details</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/becca/>Becca Hilston</a></span><time class="time published" datetime=2020-02-16T21:18:14+00:00 title="February 16, 2020 at 9:18 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time><span><a title="0 Comments" href=https://thegeekherald.com/p/black-adam-trailer-release-date-cast-plot-and-dwayne-rock-johnson-revealing-workout-details/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/the-elder-scrolls-6-major-release-date-update-confirmed-by-bethesda/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="The Elder Scrolls 6 Trailer confirmed to be Revealed at E3 2020 by Bethesda" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="The Elder Scrolls 6 Trailer confirmed to be Revealed at E3 2020 by Bethesda" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-5 post__cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/the-elder-scrolls-6-major-release-date-update-confirmed-by-bethesda/>The Elder Scrolls 6 Major Release Date Update Confirmed by Bethesda</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/chad/>Chad Hillston</a></span><time class="time published" datetime=2020-02-16T20:18:00+00:00 title="February 16, 2020 at 8:18 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time><span><a title="0 Comments" href=https://thegeekherald.com/p/the-elder-scrolls-6-major-release-date-update-confirmed-by-bethesda/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/lucifer-season-6-netflix-release-status-confirmed/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Lucifer Season 6 Renewed at Netflix after Immense Global Popularity of the Devil Show" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt="Lucifer Season 6 Renewed at Netflix after Immense Global Popularity of the Devil Show" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-5 post__cat cat-theme" href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/lucifer-season-6-netflix-release-status-confirmed/>Lucifer Season 6 Netflix Release Status Confirmed</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/emily/>Emily Hattson</a></span><time class="time published" datetime=2020-02-16T19:08:44+00:00 title="February 16, 2020 at 7:08 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time><span><a title="0 Comments" href=https://thegeekherald.com/p/lucifer-season-6-netflix-release-status-confirmed/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div></div></div></div></div><div class="mnmd-sub-col sidebar js-sticky-sidebar" role=complementary><div class=theiaStickySidebar><div id=bk_widget_posts_list-2 class="widget mnmd-widget"><div class=mnmd-widget-indexed-posts-a><div class="widget__title block-heading block-heading--line"><h4 class="widget__title-text">Latest</h4></div><ol class="posts-list list-space-sm list-unstyled"><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Matrix-4-Huge-Neo-Plot-Spoilers-Leaked-ahead-of-Release-Date-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/matrix-4-huge-neo-plot-spoilers-leaked-ahead-of-release-date/>Matrix 4 Huge Neo Plot Spoilers Leaked ahead of Release Date</a></h3><div class=post__meta><time class="time published" datetime=2020-03-08T19:48:47+00:00 title="March 8, 2020 at 7:48 pm"><i class="mdicon mdicon-schedule"></i>9 seconds ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Stranger-Things-Season-4-New-Cast-and-Characters-reveals-Major-Plot-Spoilers-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/stranger-things-season-4-new-cast-and-characters-reveals-major-plot-spoilers/>Stranger Things Season 4 New Cast and Characters reveals Major Plot Spoilers</a></h3><div class=post__meta><time class="time published" datetime=2020-03-08T19:29:18+00:00 title="March 8, 2020 at 7:29 pm"><i class="mdicon mdicon-schedule"></i>20 mins ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/coronavirus-survival-ratio-symptoms-treatment-and-everything-you-need-to-know/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Coronavirus-Survival-Ratio-Symptoms-Treatment-and-Everything-you-Need-to-Know-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/coronavirus-survival-ratio-symptoms-treatment-and-everything-you-need-to-know/>Coronavirus Survival Ratio, Symptoms, Treatment and Everything you Need to Know</a></h3><div class=post__meta><time class="time published" datetime=2020-03-08T19:24:37+00:00 title="March 8, 2020 at 7:24 pm"><i class="mdicon mdicon-schedule"></i>24 mins ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/rick-and-morty-season-4-episode-6-release-date-new-trailer-teases-part-two-of-fourth-season/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Rick and Morty Season 4 Episode 6 Release Date New Trailer teases Part Two of Fourth Season" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Rick and Morty Season 4 Episode 6 Release Date New Trailer teases Part Two of Fourth Season" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Rick and Morty Season 4 Episode 6 Release Date New Trailer teases Part Two of Fourth Season" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/03/Rick-and-Morty-Season-4-Episode-6-Release-Date-New-Trailer-teases-Part-Two-of-Fourth-Season-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/rick-and-morty-season-4-episode-6-release-date-new-trailer-teases-part-two-of-fourth-season/>Rick and Morty Season 4 Episode 6 Release Date: New Trailer teases Part Two of Fourth Season</a></h3><div class=post__meta><time class="time published" datetime=2020-03-08T19:12:19+00:00 title="March 8, 2020 at 7:12 pm"><i class="mdicon mdicon-schedule"></i>37 mins ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/black-adam-trailer-release-date-cast-plot-and-dwayne-rock-johnson-revealing-workout-details/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#039;Rock&#039; Johnson Revealing Workout Details" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#039;Rock&#039; Johnson Revealing Workout Details" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#039;Rock&#039; Johnson Revealing Workout Details" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Black-Adam-Trailer-Release-Date-Cast-Plot-and-Dwayne-Rock-Johnson-Revealing-Workout-Details-e1581887859353-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/black-adam-trailer-release-date-cast-plot-and-dwayne-rock-johnson-revealing-workout-details/>Black Adam Trailer, Release Date, Cast, Plot and Dwayne &#8216;Rock&#8217; Johnson Revealing Workout Details</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T21:18:14+00:00 title="February 16, 2020 at 9:18 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/the-elder-scrolls-6-major-release-date-update-confirmed-by-bethesda/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Elder Scrolls 6 Trailer confirmed to be Revealed at E3 2020 by Bethesda" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Elder Scrolls 6 Trailer confirmed to be Revealed at E3 2020 by Bethesda" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Elder Scrolls 6 Trailer confirmed to be Revealed at E3 2020 by Bethesda" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Elder-Scrolls-6-Trailer-confirmed-to-be-Revealed-at-E3-2020-by-Bethesda-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/the-elder-scrolls-6-major-release-date-update-confirmed-by-bethesda/>The Elder Scrolls 6 Major Release Date Update Confirmed by Bethesda</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T20:18:00+00:00 title="February 16, 2020 at 8:18 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/lucifer-season-6-netflix-release-status-confirmed/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Lucifer Season 6 Renewed at Netflix after Immense Global Popularity of the Devil Show" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Lucifer Season 6 Renewed at Netflix after Immense Global Popularity of the Devil Show" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Lucifer Season 6 Renewed at Netflix after Immense Global Popularity of the Devil Show" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Lucifer-Season-6-Renewed-at-Netflix-after-Immense-Global-Popularity-of-the-Devil-Show-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/lucifer-season-6-netflix-release-status-confirmed/>Lucifer Season 6 Netflix Release Status Confirmed</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T19:08:44+00:00 title="February 16, 2020 at 7:08 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/google-pixel-5-release-date-price-specs-features-leaks-rumors-design-and-battery-updates/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Google Pixel 5 Release Date, Price, Specs, Features, Leaks, Rumors, Design and Battery Updates" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Google Pixel 5 Release Date, Price, Specs, Features, Leaks, Rumors, Design and Battery Updates" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Google Pixel 5 Release Date, Price, Specs, Features, Leaks, Rumors, Design and Battery Updates" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Google-Pixel-5-Release-Date-Price-Specs-Features-Leaks-Rumors-Design-and-Battery-Updates-e1581878935384-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/google-pixel-5-release-date-price-specs-features-leaks-rumors-design-and-battery-updates/>Google Pixel 5 Release Date, Price, Specs, Features, Leaks, Rumors, Design and Battery Updates</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T18:49:19+00:00 title="February 16, 2020 at 6:49 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/stranger-things-season-4-from-russia-with-love-teaser-how-is-jim-hopper-alive-explained/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Stranger Things Season 4 From Russia with Love Teaser How is Jim Hopper Alive Explained" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Stranger Things Season 4 From Russia with Love Teaser How is Jim Hopper Alive Explained" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Stranger Things Season 4 From Russia with Love Teaser How is Jim Hopper Alive Explained" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Stranger-Things-Season-4-From-Russia-with-Love-Teaser-How-is-Jim-Hopper-Alive-Explained-e1581877470118-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/stranger-things-season-4-from-russia-with-love-teaser-how-is-jim-hopper-alive-explained/>Stranger Things Season 4 From Russia with Love Teaser: How is Jim Hopper Alive Explained?</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T18:26:22+00:00 title="February 16, 2020 at 6:26 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/the-witcher-season-2-will-have-multiple-witchers-from-the-games-including-geralt-of-rivia/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Witcher Season 2 will have Multiple Witchers from the Games including Geralt of Rivia" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Witcher Season 2 will have Multiple Witchers from the Games including Geralt of Rivia" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Witcher Season 2 will have Multiple Witchers from the Games including Geralt of Rivia" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Witcher-Season-2-will-have-Multiple-Witchers-from-the-Games-including-Geralt-of-Rivia-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/the-witcher-season-2-will-have-multiple-witchers-from-the-games-including-geralt-of-rivia/>The Witcher Season 2 will have Multiple Witchers from the Games including Geralt of Rivia</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T18:12:56+00:00 title="February 16, 2020 at 6:12 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/the-batman-suit-reveal-angry-fans-compare-robert-pattinson-batsuit-with-daredevil/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Batman Suit Reveal Angry Fans compare Robert Pattinson Batsuit with Daredevil" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Batman Suit Reveal Angry Fans compare Robert Pattinson Batsuit with Daredevil" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="The Batman Suit Reveal Angry Fans compare Robert Pattinson Batsuit with Daredevil" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/The-Batman-Suit-Reveal-Angry-Fans-compare-Robert-Pattinson-Batsuit-with-Daredevil-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/the-batman-suit-reveal-angry-fans-compare-robert-pattinson-batsuit-with-daredevil/>The Batman Suit Reveal: Angry Fans compare Robert Pattinson Batsuit with Daredevil</a></h3><div class=post__meta><time class="time published" datetime=2020-02-16T18:04:07+00:00 title="February 16, 2020 at 6:04 pm"><i class="mdicon mdicon-schedule"></i>February 16, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/black-panther-2-trailer-release-date-filming-cast-plot-details-and-namor-as-the-main-villain/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Black Panther 2 Trailer, Release Date, Filming, Cast, Plot Details and Namor as the Main Villain" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Black Panther 2 Trailer, Release Date, Filming, Cast, Plot Details and Namor as the Main Villain" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Black Panther 2 Trailer, Release Date, Filming, Cast, Plot Details and Namor as the Main Villain" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Black-Panther-2-Trailer-Release-Date-Filming-Cast-Plot-Details-and-Namor-as-the-Main-Villain-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/black-panther-2-trailer-release-date-filming-cast-plot-details-and-namor-as-the-main-villain/>Black Panther 2 Trailer, Release Date, Filming, Cast, Plot Details and Namor as the Main Villain</a></h3><div class=post__meta><time class="time published" datetime=2020-02-15T21:56:52+00:00 title="February 15, 2020 at 9:56 pm"><i class="mdicon mdicon-schedule"></i>February 15, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/edge-of-tomorrow-2-sequel-demanded-by-tom-cruise-and-emily-blunt-fans/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Edge of Tomorrow 2 Sequel demanded by Tom Cruise and Emily Blunt Fans" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Edge of Tomorrow 2 Sequel demanded by Tom Cruise and Emily Blunt Fans" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Edge of Tomorrow 2 Sequel demanded by Tom Cruise and Emily Blunt Fans" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/Edge-of-Tomorrow-2-Sequel-demanded-by-Tom-Cruise-and-Emily-Blunt-Fans-e1578304555293-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/edge-of-tomorrow-2-sequel-demanded-by-tom-cruise-and-emily-blunt-fans/>Edge of Tomorrow 2 Sequel demanded by Tom Cruise and Emily Blunt Fans</a></h3><div class=post__meta><time class="time published" datetime=2020-02-11T20:15:13+00:00 title="February 11, 2020 at 8:15 pm"><i class="mdicon mdicon-schedule"></i>February 11, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/gi-joe-3-ever-vigilant-trailer-release-date-cast-plot-details-and-connection-with-snake-eyes-spin-off/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="GI Joe 3 Trailer, Release Date, Cast, Plot Details and connection with Snake Eyes Spin-off" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="GI Joe 3 Trailer, Release Date, Cast, Plot Details and connection with Snake Eyes Spin-off" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="GI Joe 3 Trailer, Release Date, Cast, Plot Details and connection with Snake Eyes Spin-off" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/01/GI-Joe-3-Trailer-Release-Date-Cast-Plot-Details-and-connection-with-Snake-Eyes-Spin-off-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/gi-joe-3-ever-vigilant-trailer-release-date-cast-plot-details-and-connection-with-snake-eyes-spin-off/>GI Joe 3 Ever Vigilant Trailer, Release Date, Cast, Plot Details and connection with Snake Eyes Spin-off</a></h3><div class=post__meta><time class="time published" datetime=2020-02-11T18:43:23+00:00 title="February 11, 2020 at 6:43 pm"><i class="mdicon mdicon-schedule"></i>February 11, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/microsoft-surface-book-3-release-date-specs-rumors-laptop-to-have-core-i7-intel-ice-lake-processor/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Microsoft Surface Book 3 Release Date, Specs, Rumors Laptop to have Core i7 Intel Ice Lake Processor" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Microsoft Surface Book 3 Release Date, Specs, Rumors Laptop to have Core i7 Intel Ice Lake Processor" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Microsoft Surface Book 3 Release Date, Specs, Rumors Laptop to have Core i7 Intel Ice Lake Processor" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Microsoft-Surface-Book-3-Release-Date-Specs-Rumors-Laptop-to-have-Core-i7-Intel-Ice-Lake-Processor-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/microsoft-surface-book-3-release-date-specs-rumors-laptop-to-have-core-i7-intel-ice-lake-processor/>Microsoft Surface Book 3 Release Date, Specs, Rumors: Laptop to have Core i7 Intel Ice Lake Processor</a></h3><div class=post__meta><time class="time published" datetime=2020-02-11T18:32:48+00:00 title="February 11, 2020 at 6:32 pm"><i class="mdicon mdicon-schedule"></i>February 11, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/apple-ios-14-release-date-new-features-compatibility-new-rumors-suggests-that-every-ios-13-device-will-support-ios-14-update/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-180x180.png class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Apple iOS 14 Release Date, New Features, Compatibility New Rumors suggests that Every iOS 13 Device will Support iOS 14 Update" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-180x180.png 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-150x150.png 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-400x400.png 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-600x600.png 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-180x180.png class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Apple iOS 14 Release Date, New Features, Compatibility New Rumors suggests that Every iOS 13 Device will Support iOS 14 Update" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-180x180.png 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-150x150.png 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-400x400.png 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-600x600.png 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-180x180.png class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Apple iOS 14 Release Date, New Features, Compatibility New Rumors suggests that Every iOS 13 Device will Support iOS 14 Update" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-180x180.png 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-150x150.png 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-400x400.png 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Apple-iOS-14-Release-Date-New-Features-Compatibility-New-Rumors-suggests-that-Every-iOS-13-Device-will-Support-iOS-14-Update-e1581445242499-600x600.png 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/apple-ios-14-release-date-new-features-compatibility-new-rumors-suggests-that-every-ios-13-device-will-support-ios-14-update/>Apple iOS 14 Release Date, New Features, Compatibility: New Rumors suggests that Every iOS 13 Device will Support iOS 14 Update</a></h3><div class=post__meta><time class="time published" datetime=2020-02-11T18:21:20+00:00 title="February 11, 2020 at 6:21 pm"><i class="mdicon mdicon-schedule"></i>February 11, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/pixelbook-2-release-date-specs-rumors-google-to-upgrade-its-laptop-after-samsung-galaxy-chromebook/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Pixelbook 2 Release Date, Specs, Rumors Google to Upgrade its Laptop after Samsung Galaxy Chromebook" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Pixelbook 2 Release Date, Specs, Rumors Google to Upgrade its Laptop after Samsung Galaxy Chromebook" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Pixelbook 2 Release Date, Specs, Rumors Google to Upgrade its Laptop after Samsung Galaxy Chromebook" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Pixelbook-2-Release-Date-Specs-Rumors-Google-to-Upgrade-its-Laptop-after-Samsung-Galaxy-Chromebook-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/pixelbook-2-release-date-specs-rumors-google-to-upgrade-its-laptop-after-samsung-galaxy-chromebook/>Pixelbook 2 Release Date, Specs, Rumors: Google to Upgrade its Laptop after Samsung Galaxy Chromebook</a></h3><div class=post__meta><time class="time published" datetime=2020-02-10T18:37:07+00:00 title="February 10, 2020 at 6:37 pm"><i class="mdicon mdicon-schedule"></i>February 10, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/overlord-season-4-release-date-delayed-light-novel-volume-14-has-pushed-down-the-anime-further/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Overlord Season 4 Release Date Delayed Light Novel Volume 14 has Pushed down the Anime Further" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Overlord Season 4 Release Date Delayed Light Novel Volume 14 has Pushed down the Anime Further" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Overlord Season 4 Release Date Delayed Light Novel Volume 14 has Pushed down the Anime Further" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Overlord-Season-4-Release-Date-Delayed-Light-Novel-Volume-14-has-Pushed-down-the-Anime-Further-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/overlord-season-4-release-date-delayed-light-novel-volume-14-has-pushed-down-the-anime-further/>Overlord Season 4 Release Date Delayed, Light Novel Volume 14 has Pushed down the Anime Further</a></h3><div class=post__meta><time class="time published" datetime=2020-02-10T18:15:19+00:00 title="February 10, 2020 at 6:15 pm"><i class="mdicon mdicon-schedule"></i>February 10, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/airpods-3-release-date-specs-rumors-apples-next-gen-wireless-earbuds-to-have-late-2020-launch/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="AirPods 3 Release Date, Specs, Rumors Apple&#039;s Next-Gen Wireless Earbuds to have Late 2020 Launch" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="AirPods 3 Release Date, Specs, Rumors Apple&#039;s Next-Gen Wireless Earbuds to have Late 2020 Launch" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="AirPods 3 Release Date, Specs, Rumors Apple&#039;s Next-Gen Wireless Earbuds to have Late 2020 Launch" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/AirPods-3-Release-Date-Specs-Rumors-Apples-Next-Gen-Wireless-Earbuds-to-have-Late-2020-Launch-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/airpods-3-release-date-specs-rumors-apples-next-gen-wireless-earbuds-to-have-late-2020-launch/>AirPods 3 Release Date, Specs, Rumors: Apple&#8217;s Next-Gen Wireless Earbuds to have Late 2020 Launch</a></h3><div class=post__meta><time class="time published" datetime=2020-02-09T20:03:50+00:00 title="February 9, 2020 at 8:03 pm"><i class="mdicon mdicon-schedule"></i>February 9, 2020</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/better-call-saul-season-5-premiere-date-plot-amc-confirmed-season-6-finale-leading-to-breaking-bad/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Better Call Saul Season 5 Premiere Date, Plot AMC Confirmed Season 6 Finale leading to Breaking Bad" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Better Call Saul Season 5 Premiere Date, Plot AMC Confirmed Season 6 Finale leading to Breaking Bad" srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt="Better Call Saul Season 5 Premiere Date, Plot AMC Confirmed Season 6 Finale leading to Breaking Bad" srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/02/Better-Call-Saul-Season-5-Premiere-Date-Plot-AMC-Confirmed-Season-6-Finale-leading-to-Breaking-Bad-e1581264116206-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/better-call-saul-season-5-premiere-date-plot-amc-confirmed-season-6-finale-leading-to-breaking-bad/>Better Call Saul Season 5 Premiere Date, Plot: AMC Confirmed Season 6 Finale leading to Breaking Bad</a></h3><div class=post__meta><time class="time published" datetime=2020-02-09T16:02:42+00:00 title="February 9, 2020 at 4:02 pm"><i class="mdicon mdicon-schedule"></i>February 9, 2020</time></div></div></article></li></ol></div></div><div id=text-2 class="widget widget_text"><div class=textwidget><div class="quads-location quads-ad7" id=quads-ad7 style=float:none;margin:3px;><div id=rcjsload_8f9997></div> <script>revcontentb = jQuery(window).scroll(function() {
	   var hT = jQuery('#rcjsload_8f9997').offset().top,
	       hH = jQuery('#rcjsload_8f9997').outerHeight(),
	       wH = jQuery(window).height(),
	       wS = jQuery(this).scrollTop();
     //load 1200px before
     //if (wS+2000 > (hT+hH-wH)){ 
       if(true) {
			(function() {
			var referer="";try{if(referer=document.referrer,"undefined"==typeof referer||""==referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
			var rcds = document.getElementById("rcjsload_8f9997");
			var rcel = document.createElement("script");
			rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
			rcel.type = 'text/javascript';
			rcel.src = "//trends.revcontent.com/serve.js.php?w=113448&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+encodeURIComponent(referer);
			rcel.async = true;
			rcds.appendChild(rcel);
			})();       
            revcontentb.unbind();
	   }
	});</script></div></div></div></div></div></div></div></div></div><footer class="site-footer footer-1  "><div class="site-footer__section site-footer__section--seperated site-footer__section--bordered"><div class=container><nav class="footer-menu footer-menu--bold text-center"><div class=menu-footer-container><ul id=menu-footer class="navigation navigation--footer navigation--inline"><li id=menu-item-152 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152"><a href=https://thegeekherald.com/pg/dmca-policy-notice-and-takedown-procedure/>DMCA</a></li><li id=menu-item-153 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href=https://thegeekherald.com/pg/terms-and-conditions/>Terms and Conditions</a></li><li id=menu-item-154 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-154"><a href=https://thegeekherald.com/pg/privacy-policy/>Privacy Policy</a></li><li id=menu-item-443 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-443"><a href=https://thegeekherald.com/pg/about-us/>About Us</a></li><li id=menu-item-444 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href=https://thegeekherald.com/pg/disclaimer/>Disclaimer</a></li><li id=menu-item-445 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-445"><a href=https://thegeekherald.com/pg/contact-us/>Contact Us</a></li></ul></div></nav></div></div><div class=site-footer__section><div class=container><div class=text-center>
© Copyright 2019. TheGeekHerald.com. All Rights Reserved.</div></div></div></footer><div id=mnmd-sticky-header class="sticky-header js-sticky-header "><nav class="navigation-bar navigation-bar--fullwidth hidden-xs hidden-sm "><div class=navigation-bar__inner><div class=navigation-bar__section>
<a href=#mnmd-offcanvas-primary class="offcanvas-menu-toggle navigation-bar-btn js-mnmd-offcanvas-toggle">
<i class="mdicon mdicon-menu icon--2x"></i>
</a><div class="site-logo header-logo">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></div></div><div class="navigation-wrapper navigation-bar__section js-priority-nav"><div id=sticky-main-menu class=menu-main-menu-container><ul id=menu-main-menu-1 class="navigation navigation--main navigation--inline"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div><div class="navigation-bar__section lwa lwa-template-modal">
<button type=submit class="navigation-bar-btn js-search-dropdown-toggle"><i class="mdicon mdicon-search"></i></button></div></div></nav></div><div id=mnmd-offcanvas-primary class="mnmd-offcanvas js-mnmd-offcanvas js-perfect-scrollbar"><div class=mnmd-offcanvas__title><h2 class="site-logo">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></h2><ul class="social-list list-horizontal"></ul>
<a href=#mnmd-offcanvas-primary class="mnmd-offcanvas-close js-mnmd-offcanvas-close" aria-label=Close><span aria-hidden=true>&#10005;</span></a></div><div class="mnmd-offcanvas__section mnmd-offcanvas__section-navigation"><div id=offcanvas-menu-desktop class=menu-main-menu-container><ul id=menu-main-menu-2 class="navigation navigation--offcanvas"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div></div><div id=mnmd-offcanvas-mobile class="mnmd-offcanvas js-mnmd-offcanvas js-perfect-scrollbar"><div class=mnmd-offcanvas__title><h2 class="site-logo">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></h2><ul class="social-list list-horizontal"></ul>
<a href=#mnmd-offcanvas-mobile class="mnmd-offcanvas-close js-mnmd-offcanvas-close" aria-label=Close><span aria-hidden=true>&#10005;</span></a></div><div class="mnmd-offcanvas__section mnmd-offcanvas__section-navigation"><div id=offcanvas-menu-mobile class=menu-main-menu-container><ul id=menu-main-menu-3 class="navigation navigation--offcanvas"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div></div>
<a href=# class="mnmd-go-top btn btn-default hidden-xs js-go-top-el"><i class="mdicon mdicon-arrow_upward"></i></a></div> <script>var wpcf7 = {"apiSettings":{"root":"https:\/\/thegeekherald.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script>var ajax_buff = {"tnm_security":{"tnm_security_code":{"content":"f94dba62a3"}}};</script> <script>var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};</script> <script>var a3_lazyload_extend_params = {"edgeY":"0"};</script> <script>var fv_flowplayer_conf = {"fullscreen":"1","swf":"\/\/thegeekherald.com\/wp-content\/plugins\/fv-wordpress-flowplayer\/flowplayer\/flowplayer.swf?ver=7.4.9.727","swfHls":"\/\/thegeekherald.com\/wp-content\/plugins\/fv-wordpress-flowplayer\/flowplayer\/flowplayerhls.swf?ver=7.4.9.727","speeds":[0.25,0.5,0.75,1,1.25,1.5,1.75,2],"video_hash_links":"1","safety_resize":"1","volume":"0.7","sticky_video":"","sticky_place":"right-bottom","sticky_width":"380","script_hls_js":"https:\/\/thegeekherald.com\/wp-content\/plugins\/fv-wordpress-flowplayer\/flowplayer\/hls.min.js?ver=0.11.0","script_dash_js":"https:\/\/thegeekherald.com\/wp-content\/plugins\/fv-wordpress-flowplayer\/flowplayer\/flowplayer.dashjs.min.js?ver=7.4.9.727","script_dash_js_version":"2.7","chromecast":"1","hlsjs":{"startLevel":-1,"fragLoadingMaxRetry":3,"levelLoadingMaxRetry":3,"capLevelToPlayerSize":true}};
var fv_flowplayer_translations = {"0":"","1":"Video loading aborted","2":"Network error","3":"Video not properly encoded","4":"Video file not found","5":"Unsupported video","6":"Skin not found","7":"SWF file not found","8":"Subtitles not found","9":"Invalid RTMP URL","10":"Unsupported video format. Try installing Adobe Flash.","11":"Click to watch the video","12":"[This post contains video, click to play]","video_expired":"<h2>Video file expired.<br \/>Please reload the page and play it again.<\/h2>","unsupported_format":"<h2>Unsupported video format.<br \/>Please use a Flash compatible device.<\/h2>","mobile_browser_detected_1":"Mobile browser detected, serving low bandwidth video.","mobile_browser_detected_2":"Click here","mobile_browser_detected_3":"for full quality.","live_stream_failed":"<h2>Live stream load failed.<\/h2><h3>Please try again later, perhaps the stream is currently offline.<\/h3>","live_stream_failed_2":"<h2>Live stream load failed.<\/h2><h3>Please try again later, perhaps the stream is currently offline.<\/h3>","what_is_wrong":"Please tell us what is wrong :","full_sentence":"Please give us more information (a full sentence) so we can help you better","error_JSON":"Admin: Error parsing JSON","no_support_IE9":"Admin: Video checker doesn't support IE 9.","check_failed":"Admin: Check failed.","playlist_current":"Now Playing","playlist_item_no":"Item %d.","playlist_play_all":"Play All","playlist_play_all_button":"All","playlist_replay_all":"Replay Playlist","playlist_replay_video":"Repeat Track","playlist_shuffle":"Shuffle Playlist","video_issues":"Video Issues","video_reload":"Video loading has stalled, click to reload","link_copied":"Video Link Copied to Clipboard","embed_copied":"Embed Code Copied to Clipboard","subtitles_disabled":"Subtitles disabled","subtitles_switched":"Subtitles switched to ","warning_iphone_subs":"This video has subtitles, that are not supported on your device.","warning_unstable_android":"You are using an old Android device. If you experience issues with the video please use <a href=\"https:\/\/play.google.com\/store\/apps\/details?id=org.mozilla.firefox\">Firefox<\/a>. <a target=\"_blank\" href=\"https:\/\/foliovision.com\/2017\/05\/issues-with-vimeo-on-android\">Why?<\/a>","warning_samsungbrowser":"You are using the Samsung Browser which is an older and buggy version of Google Chrome. If you experience issues with the video please use <a href=\"https:\/\/www.mozilla.org\/en-US\/firefox\/new\/\">Firefox<\/a> or other modern browser. <a target=\"_blank\" href=\"https:\/\/foliovision.com\/2017\/05\/issues-with-vimeo-on-android\">Why?<\/a>","warning_old_safari":"You are using an old Safari browser. If you experience issues with the video please use <a href=\"https:\/\/www.mozilla.org\/en-US\/firefox\/new\/\">Firefox<\/a> or other modern browser.","warning_old_chrome":"You are using an old Chrome browser. Please make sure you use the latest version.","warning_old_firefox":"You are using an old Firefox browser. Please make sure you use the latest version.","warning_old_ie":"You are using a deprecated browser. If you experience issues with the video please use <a href=\"https:\/\/www.mozilla.org\/en-US\/firefox\/new\/\">Firefox<\/a> or other modern browser."};
var fv_fp_ajaxurl = "https:\/\/thegeekherald.com\/wp-admin\/admin-ajax.php";
var fv_flowplayer_playlists = [];</script> <script>if (typeof wpquads_adblocker_check === 'undefined') {
             wpquads_adblocker_check = false;
         } else {
             wpquads_adblocker_check = true;
         }</script> <script>if (typeof ga !== 'undefined' && wpquads_adblocker_check === false) {
          ga('send', 'event', 'Blocking Ads', 'true', {'nonInteraction': true});
      } else if (typeof _gaq !== 'undefined' && wpquads_adblocker_check === false) {
          _gaq.push(['_trackEvent', 'Blocking Ads', 'true', undefined, undefined, true]);
      }</script> <script defer src=//cdn.thegeekherald.com/wp-content/cache/autoptimize/js/autoptimize_d18d8173c7753bbdf2bb9ab604b5918d.js></script></body></html>