<!DOCTYPE html><html lang=en-US><head><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1"><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Rubik:300,400,500,700,900,300italic,400italic,500italic,700italic,900italic"] },classes:false, events:false, timeout:1500};</script><link rel=profile href="https://gmpg.org/xfn/11"><link rel=pingback href=https://thegeekherald.com/xmlrpc.php> <script>var ajaxurl = "https://thegeekherald.com/wp-admin/admin-ajax.php"</script> <link media=all href=//cdn.thegeekherald.com/wp-content/cache/autoptimize/css/autoptimize_5a90dfdd85f579c40e7ae2992dd2d611.css rel=stylesheet><title>Poco M2 Pro Release Date, Specs, and Price - The Geek Herald</title><meta name=robots content="index, follow"><meta name=googlebot content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta name=bingbot content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link rel=canonical href=https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Poco M2 Pro Release Date, Specs, and Price - The Geek Herald"><meta property=og:description content="Poco India announced Poco M2 Pro in a live stream event Wednesday, highlighting some features including a quad-camera setup on the rear and a huge battery pack with advanced fast-charging tech. Poco M2 Pro Features Detail A box located at the upper center of the device contains the rear cameras. The cameras composed of a 48-megapixel wide lens along with 8MP ultrawide, 5MP macro, and 2MP depth shutters. Satisfying enough for fans of phone photography. Poco M2 Pro fans can also record a video with quality as high as 4K@30fps for the rear cameras. For the 16MP selfie camera, it [&hellip;]"><meta property=og:url content=https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/><meta property=og:site_name content="The Geek Herald"><meta property=article:published_time content=2020-07-09T13:50:07+00:00><meta property=og:image content=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco.jpeg><meta property=og:image:width content=900><meta property=og:image:height content=506><meta name=twitter:card content=summary_large_image> <script type=application/ld+json class=yoast-schema-graph>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://thegeekherald.com/#organization","name":"The Geek Herald","url":"https://thegeekherald.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://thegeekherald.com/#logo","inLanguage":"en-US","url":"https://cdn.thegeekherald.com/wp-content/uploads/2019/06/Copy-of-Copy-of-The-Geek-Herald.png","width":70,"height":60,"caption":"The Geek Herald"},"image":{"@id":"https://thegeekherald.com/#logo"}},{"@type":"WebSite","@id":"https://thegeekherald.com/#website","url":"https://thegeekherald.com/","name":"The Geek Herald","description":"#1 Geek News Portal","publisher":{"@id":"https://thegeekherald.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://thegeekherald.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#primaryimage","inLanguage":"en-US","url":"https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco.jpeg","width":900,"height":506},{"@type":"WebPage","@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#webpage","url":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/","name":"Poco M2 Pro Release Date, Specs, and Price - The Geek Herald","isPartOf":{"@id":"https://thegeekherald.com/#website"},"primaryImageOfPage":{"@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#primaryimage"},"datePublished":"2020-07-09T13:50:07+00:00","dateModified":"2020-07-09T13:50:07+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/"]}]},{"@type":"Article","@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#article","isPartOf":{"@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#webpage"},"author":{"@id":"https://thegeekherald.com/#/schema/person/11794f3b449a0a8c61055cf4a8c98ae4"},"headline":"Poco M2 Pro Release Date, Specs, and Price","datePublished":"2020-07-09T13:50:07+00:00","dateModified":"2020-07-09T13:50:07+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#webpage"},"publisher":{"@id":"https://thegeekherald.com/#organization"},"image":{"@id":"https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/#primaryimage"},"keywords":"Battery Pack,Poco India,Poco M2 Pro,Quad Camera","articleSection":"Technology","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://thegeekherald.com/#/schema/person/11794f3b449a0a8c61055cf4a8c98ae4","name":"Fazlur Rahman"}]}</script> <link rel=amphtml href=https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/amp/><meta name=generator content="AMP for WP 1.0.52"><link href=https://fonts.gstatic.com crossorigin=anonymous rel=preconnect><link href=https://ajax.googleapis.com rel=preconnect><link href=https://fonts.googleapis.com rel=preconnect><link rel=alternate type=application/rss+xml title="The Geek Herald &raquo; Feed" href=https://thegeekherald.com/feed/><link rel=stylesheet id=a3a3_lazy_load-css href=https://cdn.thegeekherald.com/wp-content/uploads/sass/a3_lazy_load.min.css type=text/css media=all> <script src=https://cdn.thegeekherald.com/wp-includes/js/jquery/jquery.x84726.js></script> <link rel=https://api.w.org/ href=https://thegeekherald.com/wp-json/><link rel=EditURI type=application/rsd+xml title=RSD href=https://thegeekherald.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://cdn.thegeekherald.com/wp-includes/wlwmanifest.xml><link rel=shortlink href='https://thegeekherald.com/?p=20392'><link rel=alternate type=application/json+oembed href="https://thegeekherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><link rel=alternate type=text/xml+oembed href="https://thegeekherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F&#038;format=xml"> <script type=application/ld+json>{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/thegeekherald.com\/p\/poco-m2-pro-release-date-specs-and-price\/"},"url":"https:\/\/thegeekherald.com\/p\/poco-m2-pro-release-date-specs-and-price\/","headline":"Poco M2 Pro Release Date, Specs, and...","datePublished":"2020-07-09T13:50:07+00:00","dateModified":"2020-07-09T13:50:07+00:00","publisher":{"@type":"Organization","@id":"https:\/\/thegeekherald.com\/#organization","name":"The Geek Herald","logo":{"@type":"ImageObject","url":"https:\/\/cdn.thegeekherald.com\/wp-content\/uploads\/2019\/06\/Copy-of-Copy-of-The-Geek-Herald.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/thegeekherald.com\/wp-content\/uploads\/2020\/07\/poco.jpeg","width":900,"height":506},"articleSection":"Technology","description":"Poco India announced Poco M2 Pro in a live stream event Wednesday, highlighting some features including a quad-camera setup on the rear and a huge battery pack with advanced fast-charging tech. Poco M2 Pro Features Detail A box located at the upper center of the device contains the rear","author":{"@type":"Person","name":"Fazlur Rahman","url":"https:\/\/thegeekherald.com\/p\/author\/fazlur\/","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/c102459e1f035d85c13de7fddc9ffa69?s=96&d=mm&r=g","height":96,"width":96}},"video":[]}</script> <script src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script><script>document.cookie = 'quads_browser_width='+screen.width;</script> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-18309869-35"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-18309869-35');</script> <script type=application/ld+json>{
    "@context": "http://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https://thegeekherald.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/",
                "name": "Poco M2 Pro Release Date, Specs, and Price",
                "image": "https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco.jpeg"
            }
        }
    ]
}</script> <meta name=pocket-site-verification content=dc4fece5c7b981ddda35379625857e><link rel=icon href=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-150x150.png sizes=32x32><link rel=icon href=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-300x300.png sizes=192x192><link rel=apple-touch-icon href=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-180x180.png><meta name=msapplication-TileImage content=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Gold-Quasars-1-300x300.png><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-20392 single-format-standard header-1">
<div class=site-wrapper><header class=site-header><div class="header-main hidden-xs hidden-sm"><div class=container><div class="row row--flex row--vertical-center"><div class=col-xs-3><div class=header-social><ul class="social-list social-list--lg list-horizontal"></ul></div></div><div class=col-xs-6><div class="header-logo text-center">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo width=200px>
</a></div></div><div class="col-xs-3 text-right"></div></div></div></div><div id=mnmd-mobile-header class="mobile-header visible-xs visible-sm "><div class="mobile-header__inner mobile-header__inner--flex"><div class="header-branding header-branding--mobile mobile-header__section text-left"><div class="header-logo header-logo--mobile flexbox__item text-left">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></div></div><div class="mobile-header__section text-right">
<button type=submit class="mobile-header-btn js-search-dropdown-toggle">
<span class=hidden-xs>Search</span><i class="mdicon mdicon-search mdicon--last hidden-xs"></i><i class="mdicon mdicon-search visible-xs-inline-block"></i>
</button>
<a href=#mnmd-offcanvas-mobile class="offcanvas-menu-toggle mobile-header-btn js-mnmd-offcanvas-toggle">
<span class=hidden-xs>Menu</span><i class="mdicon mdicon-menu mdicon--last hidden-xs"></i><i class="mdicon mdicon-menu visible-xs-inline-block"></i>
</a></div></div></div><nav class="navigation-bar hidden-xs hidden-sm js-sticky-header-holder"><div class=container><div class=navigation-bar__inner><div class="navigation-bar__section hidden-xs hidden-sm">
<a href=#mnmd-offcanvas-primary class="offcanvas-menu-toggle navigation-bar-btn js-mnmd-offcanvas-toggle"><i class="mdicon mdicon-menu"></i></a></div><div class="navigation-wrapper navigation-bar__section js-priority-nav"><div id=main-menu class=menu-main-menu-container><ul id=menu-main-menu class="navigation navigation--main navigation--inline"><li id=menu-item-141 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li id=menu-item-142 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li id=menu-item-143 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li id=menu-item-144 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li id=menu-item-145 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div><div class="navigation-bar__section lwa lwa-template-modal">
<button type=submit class="navigation-bar-btn js-search-dropdown-toggle"><i class="mdicon mdicon-search"></i></button></div></div><div id=header-search-dropdown class="header-search-dropdown ajax-search is-in-navbar js-ajax-search"><div class="container container--narrow"><form class="search-form search-form--horizontal" method=get action=https://thegeekherald.com/><div class=search-form__input-wrap>
<input type=text name=s class=search-form__input placeholder=Search value></div><div class=search-form__submit-wrap>
<button type=submit class="search-form__submit btn btn-primary">Search</button></div></form><div class=search-results><div class=typing-loader></div><div class=search-results__inner></div></div></div></div></div></nav></header><div class="quads-location quads-ad4" id=quads-ad4 style="float:none;margin:10px 0px 0px 0px;text-align:center;"> <script>var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:970px;height:90px; data-ad-client=pub-5748521297210733 data-ad-slot=6014974082 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:728px;height:90px; data-ad-client=pub-5748521297210733 data-ad-slot=6014974082 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:728px;height:90px; data-ad-client=pub-5748521297210733 data-ad-slot=6014974082 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }</script> </div><div class="site-content single-entry"><div class="mnmd-block mnmd-block--fullwidth single-entry-wrap"><div class=container><div class=row><div class="mnmd-main-col " role=main><article class="mnmd-block post--single post-20392 post type-post status-publish format-standard has-post-thumbnail hentry category-technology tag-battery-pack tag-poco-india tag-poco-m2-pro tag-quad-camera"><div class=single-content><header class=single-header>
<a class="cat-4 post__cat cat-theme" href=https://thegeekherald.com/p/category/technology/>Technology</a><h1 class="entry-title">Poco M2 Pro Release Date, Specs, and Price</h1><div class=entry-meta>
<span class="entry-author entry-author--with-ava">
By <a class=entry-author__name title="Posts by Fazlur Rahman" rel=author href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a> </span>
<time class="time published" datetime=2020-07-09T13:50:07+00:00 title="July 9, 2020 at 1:50 pm"><i class="mdicon mdicon-schedule"></i>13 mins ago</time></div></header><div class="entry-interaction entry-interaction--horizontal"><div class=entry-interaction__left><div class="post-sharing post-sharing--simple"><ul><li><a class="sharing-btn sharing-btn-primary facebook-btn facebook-theme-bg" data-toggle=tooltip data-placement=top title="Share on Facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><i class="mdicon mdicon-facebook"></i><span class=sharing-btn__text>Share</span></a></li><li><a class="sharing-btn sharing-btn-primary twitter-btn twitter-theme-bg" data-toggle=tooltip data-placement=top title="Share on Twitter" onClick="window.open('http://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F&amp;text=Poco%20M2%20Pro%20Release%20Date,%20Specs,%20and%20Price','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F&amp;text=Poco%20M2%20Pro%20Release%20Date,%20Specs,%20and%20Price"><i class="mdicon mdicon-twitter"></i><span class=sharing-btn__text>Tweet</span></a></li><li><a class="sharing-btn googleplus-btn googleplus-theme-bg" data-toggle=tooltip data-placement=top title="Share on Google+" onClick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><i class="mdicon mdicon-google-plus"></i></a></li><li><a class="sharing-btn pinterest-btn pinterest-theme-bg" data-toggle=tooltip data-placement=top title="Share on Pinterest" href="javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;http://assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());"><i class="mdicon mdicon-pinterest-p"></i></a></li><li><a class="sharing-btn linkedin-btn linkedin-theme-bg" data-toggle=tooltip data-placement=top title="Share on Linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><i class="mdicon mdicon-linkedin"></i></a></li></ul></div></div><div class=entry-interaction__right>
<a href=#comments class="comments-count entry-action-btn" data-toggle=tooltip data-placement=top title="0 Comments"><i class="mdicon mdicon-chat_bubble"></i><span>0</span></a></div></div><div class="entry-thumb single-entry-thumb"><img width=800 height=400 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-800x400.jpeg class="lazy lazy-hidden attachment-tnm-m-2_1 size-tnm-m-2_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-800x400.jpeg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-400x200.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-600x300.jpeg 600w" sizes="(max-width: 800px) 100vw, 800px"><noscript><img
width=800 height=400 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-800x400.jpeg class="attachment-tnm-m-2_1 size-tnm-m-2_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-800x400.jpeg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-400x200.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-600x300.jpeg 600w" sizes="(max-width: 800px) 100vw, 800px"></noscript></div><div class="single-body entry-content typography-copy"><div class="quads-location quads-ad1" id=quads-ad1 style="float:none;margin:3px 0 3px 0;text-align:center;"> <script>var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width < 768 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:300px;height:250px; data-ad-client=pub-5748521297210733 data-ad-slot=5360367961 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }</script> </div><p>Poco India announced Poco M2 Pro in a live stream event Wednesday, highlighting some features including a quad-camera setup on the rear and a huge battery pack with advanced fast-charging tech.</p><h4>Poco M2 Pro Features Detail</h4><p>A box located at the upper center of the device contains the rear cameras. The cameras composed of a 48-megapixel wide lens along with 8MP ultrawide, 5MP macro, and 2MP depth shutters. Satisfying enough for fans of phone photography. Poco M2 Pro fans can also record a video with quality as high as <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="77433c374447110704">[email&#160;protected]</a> for the rear cameras. For the 16MP selfie camera, it supports 1080p videos at 30fps or 120fps.</p><p>The battery is also one of its main attractions. This device has a 5,000 mAh battery pack along with a 33W fast charger. The Xiaomi spinoff claims that the battery can go from 0 to 50% in under 30 minutes.</p><blockquote class=twitter-tweet data-width=550 data-dnt=true><p lang=en dir=ltr>Hear, hear, photography enthusiasts!</p><p>Shoot in RAW on the <a href="https://twitter.com/hashtag/POCOM2Pro?src=hash&amp;ref_src=twsrc%5Etfw">#POCOM2Pro</a> for more flexibility in photo editing. Every photographer&#39;s dream come true.</p><p>RT now, thank us later. <a href="https://twitter.com/hashtag/FeelTheSurge?src=hash&amp;ref_src=twsrc%5Etfw">#FeelTheSurge</a> <a href=https://t.co/wOQTqsXlFB>pic.twitter.com/wOQTqsXlFB</a></p><div class="quads-location quads-ad2" id=quads-ad2 style="float:none;margin:0px 0px 10px 0px;text-align:center;"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:640px;height:300px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }if ( quads_screen_width < 768 ) {document.write('<ins class=adsbygoogle style=display:inline-block;width:300px;height:250px; data-ad-client=pub-5748521297210733 data-ad-slot=1388978147 ></ins>');
            (adsbygoogle = window.adsbygoogle || []).push({});
            }</script> </div><p>&mdash; #POCOForIndia (@IndiaPOCO) <a href="https://twitter.com/IndiaPOCO/status/1280397986892115968?ref_src=twsrc%5Etfw">July 7, 2020</a></p></blockquote><p><script async src=https://platform.twitter.com/widgets.js charset=utf-8></script></p><p>These features and specs are interesting, but it is not yet the flagship smartphone model from Poco India. Consumers are waiting for the company to release a smartphone with Qualcomm’s latest top-tier mobile platform, the Snapdragon 865. While for this phone, Poco India equips it with a Qualcomm Snapdragon 720G.</p><p>Fans are commenting on the official post for Poco M2 Pro on <a href=https://twitter.com/IndiaPOCO/status/1280397986892115968>Twitter</a>, arguing that this phone is a rebranded of Xiaomi Redmi Note 9 Pro. However, people should notice that Poco M2 Pro can be a competitive smartphone, especially for its lower price.</p><h4>Poco M2 Pro Price and Configurations</h4><p>Fans can have the base model with 4GB RAM and 64GB storage for Rs. 13,999. Spending more money, users can have the RAM upgraded to 6GB at Rs. 14,999. The highest configuration is a 6GB RAM and 128GB storage for Rs. 16,999.</p><p>This phone will be released in India starting July 14 through Flipkart.<div class="quads-location quads-ad11" id=quads-ad11 style="float:none;margin:3px 0 3px 0;text-align:center;"><div id=M583453ScriptRootC948285></div> <script src=https://jsc.mgid.com/t/h/thegeekherald.com.948285.js async></script> </div></div><footer class="single-footer entry-footer"><div class=entry-info><div class="row row--space-between grid-gutter-10"><div class="entry-categories col-sm-6"><ul><li class=entry-categories__icon><i class="mdicon mdicon-folder"></i><span class=sr-only>Posted in</span></li><li><a class="cat-4 entry-cat cat-theme" href=https://thegeekherald.com/p/category/technology/>Technology</a></li></ul></div><div class="entry-tags col-sm-6"><ul><li class=entry-tags__icon><i class="mdicon mdicon-local_offer"></i><span class=sr-only>Tagged with</span></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/battery-pack/>Battery Pack</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/poco-india/>Poco India</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/poco-m2-pro/>Poco M2 Pro</a></li><li><a class=post-tag rel=tag href=https://thegeekherald.com/p/tag/quad-camera/>Quad Camera</a></li></ul></div></div></div><div class="entry-interaction entry-interaction--horizontal"><div class=entry-interaction__left><div class="post-sharing post-sharing--simple"><ul><li><a class="sharing-btn sharing-btn-primary facebook-btn facebook-theme-bg" data-toggle=tooltip data-placement=top title="Share on Facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><i class="mdicon mdicon-facebook"></i><span class=sharing-btn__text>Share</span></a></li><li><a class="sharing-btn sharing-btn-primary twitter-btn twitter-theme-bg" data-toggle=tooltip data-placement=top title="Share on Twitter" onClick="window.open('http://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F&amp;text=Poco%20M2%20Pro%20Release%20Date,%20Specs,%20and%20Price','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F&amp;text=Poco%20M2%20Pro%20Release%20Date,%20Specs,%20and%20Price"><i class="mdicon mdicon-twitter"></i><span class=sharing-btn__text>Tweet</span></a></li><li><a class="sharing-btn googleplus-btn googleplus-theme-bg" data-toggle=tooltip data-placement=top title="Share on Google+" onClick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><i class="mdicon mdicon-google-plus"></i></a></li><li><a class="sharing-btn pinterest-btn pinterest-theme-bg" data-toggle=tooltip data-placement=top title="Share on Pinterest" href="javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;http://assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());"><i class="mdicon mdicon-pinterest-p"></i></a></li><li><a class="sharing-btn linkedin-btn linkedin-theme-bg" data-toggle=tooltip data-placement=top title="Share on Linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fthegeekherald.com%2Fp%2Fpoco-m2-pro-release-date-specs-and-price%2F"><i class="mdicon mdicon-linkedin"></i></a></li></ul></div></div><div class=entry-interaction__right>
<a href=#comments class="comments-count entry-action-btn" data-toggle=tooltip data-placement=top title="0 Comments"><i class="mdicon mdicon-chat_bubble"></i><span>0</span></a></div></div></footer></div></article><div class="quads-location quads-ad6" id=quads-ad6 style="float:none;margin:3px 0 3px 0;text-align:center;"></div><div class="posts-navigation single-entry-section clearfix"><div class=posts-navigation__prev><article class="post--overlay post--overlay-bottom post--overlay-floorfade"><div class=background-img style="background-image: url('https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW__2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-231x225.jpg');"></div><div class="post__text inverse-text"><div class=post__text-wrap><div class=post__text-inner><h3 class="post__title typescale-1">The Sims 5 Release Date and Compatibility with Nintendo Switch</h3></div></div></div><a href=https://thegeekherald.com/p/the-sims-5-release-date-and-compatibility-with-nintendo-switch/ class=link-overlay></a></article><a class=posts-navigation__label href=https://thegeekherald.com/p/the-sims-5-release-date-and-compatibility-with-nintendo-switch/><span><i class="mdicon mdicon-arrow_back"></i>Previous article</span></a></div></div><div class="related-posts single-entry-section"><div class="block-heading "><h4 class="block-heading__title">You may also like</h4></div><div class=posts-list><div class="posts-list list-space-xl"><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/samsung-electronics-expects-high-profit-in-q2/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-1200x900.jpg 1200w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-3 post__cat cat-theme" href=https://thegeekherald.com/p/category/news/>News</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/samsung-electronics-expects-high-profit-in-q2/>Samsung Electronics Expects High Profit in Q2</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a></span><time class="time published" datetime=2020-07-08T14:37:11+00:00 title="July 8, 2020 at 2:37 pm"><i class="mdicon mdicon-schedule"></i>23 hours ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/samsung-electronics-expects-high-profit-in-q2/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/20375/><img width=380 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-380x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt><noscript><img
width=380 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-380x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt></noscript></a></div><div class="post__text ">
<a class="cat-1982 post__cat cat-theme" href=https://thegeekherald.com/p/category/gaming/>Gaming</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/20375/>300,000 Nintendo Switch Accounts Have Been Hacked</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a></span><time class="time published" datetime=2020-07-08T14:01:36+00:00 title="July 8, 2020 at 2:01 pm"><i class="mdicon mdicon-schedule"></i>1 day ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/20375/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/tesla-model-3-now-has-cabin-camera-activated/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-1200x900.jpg 1200w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-1600x1200.jpg 1600w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-800x600.jpg 800w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-1200x900.jpg 1200w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-1600x1200.jpg 1600w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-35 post__cat cat-theme" href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/tesla-model-3-now-has-cabin-camera-activated/>Tesla Model 3 Now Has Cabin Camera Activated</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a></span><time class="time published" datetime=2020-07-08T13:44:56+00:00 title="July 8, 2020 at 1:44 pm"><i class="mdicon mdicon-schedule"></i>1 day ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/tesla-model-3-now-has-cabin-camera-activated/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div></div></div></div><div class="same-category-posts single-entry-section"><div class="block-heading "><h4 class="block-heading__title">More in <a href=https://thegeekherald.com/p/category/technology/ class="cat-4 cat-theme">Technology</a></h4></div><div class=posts-list><div class="posts-list list-space-xl"><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/tesla-cybertruck-release-date-and-features/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-600x450.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-800x600.jpg 800w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-35 post__cat cat-theme" href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/tesla-cybertruck-release-date-and-features/>Tesla Cybertruck Release Date and Features</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a></span><time class="time published" datetime=2020-07-08T13:31:07+00:00 title="July 8, 2020 at 1:31 pm"><i class="mdicon mdicon-schedule"></i>1 day ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/tesla-cybertruck-release-date-and-features/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/samsung-is-leading-southeast-asian-market-beating-its-chinese-rivals/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x300.jpeg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x300.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x135.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-600x450.jpeg 600w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x300.jpeg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x300.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x135.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-600x450.jpeg 600w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-4 post__cat cat-theme" href=https://thegeekherald.com/p/category/technology/>Technology</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/samsung-is-leading-southeast-asian-market-beating-its-chinese-rivals/>Samsung Is Leading Southeast Asian Market, Beating Its Chinese Rivals</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a></span><time class="time published" datetime=2020-07-07T14:40:35+00:00 title="July 7, 2020 at 2:40 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/samsung-is-leading-southeast-asian-market-beating-its-chinese-rivals/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div><div class=list-item><article class="post post--horizontal post--horizontal-sm"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/gopro-hero-9-release-date-comes-with-dual-screens/><img width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x300.jpg class="lazy lazy-hidden attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-600x450.jpg 600w" sizes="(max-width: 400px) 100vw, 400px"><noscript><img
width=400 height=300 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x300.jpg class="attachment-tnm-xs-4_3 size-tnm-xs-4_3 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x300.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x135.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-600x450.jpg 600w" sizes="(max-width: 400px) 100vw, 400px"></noscript></a></div><div class="post__text ">
<a class="cat-4 post__cat cat-theme" href=https://thegeekherald.com/p/category/technology/>Technology</a><h3 class="post__title typescale-2"><a href=https://thegeekherald.com/p/gopro-hero-9-release-date-comes-with-dual-screens/>GoPro Hero 9 Release Date, Comes with Dual Screens</a></h3><div class=post__meta><span class=entry-author> By <a class=entry-author__name href=https://thegeekherald.com/p/author/fazlur/>Fazlur Rahman</a></span><time class="time published" datetime=2020-07-07T14:16:38+00:00 title="July 7, 2020 at 2:16 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time><span><a title="0 Comments" href=https://thegeekherald.com/p/gopro-hero-9-release-date-comes-with-dual-screens/><i class="mdicon mdicon-chat_bubble_outline"></i>0</a></span></div></div></article></div></div></div></div></div><div class="mnmd-sub-col sidebar js-sticky-sidebar" role=complementary><div class=theiaStickySidebar><div id=bk_widget_posts_list-2 class="widget mnmd-widget"><div class=mnmd-widget-indexed-posts-a><div class="widget__title block-heading block-heading--line"><h4 class="widget__title-text">Latest</h4></div><ol class="posts-list list-space-sm list-unstyled"><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-400x400.jpeg 400w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-400x400.jpeg 400w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/poco-400x400.jpeg 400w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/poco-m2-pro-release-date-specs-and-price/>Poco M2 Pro Release Date, Specs, and Price</a></h3><div class=post__meta><time class="time published" datetime=2020-07-09T13:50:07+00:00 title="July 9, 2020 at 1:50 pm"><i class="mdicon mdicon-schedule"></i>13 mins ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/the-sims-5-release-date-and-compatibility-with-nintendo-switch/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/1011164_LB_231x326_en_WW_^_2019-06-26-09-34-45_7105a6cedde2619568d0d477bcf460506034f67d-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/the-sims-5-release-date-and-compatibility-with-nintendo-switch/>The Sims 5 Release Date and Compatibility with Nintendo Switch</a></h3><div class=post__meta><time class="time published" datetime=2020-07-08T14:52:30+00:00 title="July 8, 2020 at 2:52 pm"><i class="mdicon mdicon-schedule"></i>23 hours ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/samsung-electronics-expects-high-profit-in-q2/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/Samsung-Galaxy-Fold-24-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/samsung-electronics-expects-high-profit-in-q2/>Samsung Electronics Expects High Profit in Q2</a></h3><div class=post__meta><time class="time published" datetime=2020-07-08T14:37:11+00:00 title="July 8, 2020 at 2:37 pm"><i class="mdicon mdicon-schedule"></i>23 hours ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/20375/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/TEMP_img-01-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/20375/>300,000 Nintendo Switch Accounts Have Been Hacked</a></h3><div class=post__meta><time class="time published" datetime=2020-07-08T14:01:36+00:00 title="July 8, 2020 at 2:01 pm"><i class="mdicon mdicon-schedule"></i>1 day ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/tesla-model-3-now-has-cabin-camera-activated/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/model-3-hero-desktop-v2-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/tesla-model-3-now-has-cabin-camera-activated/>Tesla Model 3 Now Has Cabin Camera Activated</a></h3><div class=post__meta><time class="time published" datetime=2020-07-08T13:44:56+00:00 title="July 8, 2020 at 1:44 pm"><i class="mdicon mdicon-schedule"></i>1 day ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/tesla-cybertruck-release-date-and-features/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/p-social-card-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/tesla-cybertruck-release-date-and-features/>Tesla Cybertruck Release Date and Features</a></h3><div class=post__meta><time class="time published" datetime=2020-07-08T13:31:07+00:00 title="July 8, 2020 at 1:31 pm"><i class="mdicon mdicon-schedule"></i>1 day ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/samsung-is-leading-southeast-asian-market-beating-its-chinese-rivals/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x400.jpeg 400w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x400.jpeg 400w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/id-feature-chic-design-with-a-contemporary-look-216251121-400x400.jpeg 400w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/samsung-is-leading-southeast-asian-market-beating-its-chinese-rivals/>Samsung Is Leading Southeast Asian Market, Beating Its Chinese Rivals</a></h3><div class=post__meta><time class="time published" datetime=2020-07-07T14:40:35+00:00 title="July 7, 2020 at 2:40 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/gopro-hero-9-release-date-comes-with-dual-screens/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-300x300.jpg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-600x600.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod.jpg 750w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-300x300.jpg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-600x600.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod.jpg 750w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-300x300.jpg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod-600x600.jpg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/gopro-display-mod.jpg 750w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/gopro-hero-9-release-date-comes-with-dual-screens/>GoPro Hero 9 Release Date, Comes with Dual Screens</a></h3><div class=post__meta><time class="time published" datetime=2020-07-07T14:16:38+00:00 title="July 7, 2020 at 2:16 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/cyberpunk-2077-release-date-and-compatibility-issue/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-600x600.jpeg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01.jpeg 640w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-600x600.jpeg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01.jpeg 640w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01-600x600.jpeg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/092302500_1560672731-cyberpunk2077-01.jpeg 640w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/cyberpunk-2077-release-date-and-compatibility-issue/>Cyberpunk 2077 Release Date and Compatibility Issue</a></h3><div class=post__meta><time class="time published" datetime=2020-07-07T13:41:40+00:00 title="July 7, 2020 at 1:41 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/world-of-warcraft-weekly-event-extra-honor-gains/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/card-world-of-warcraft-54576e6364584e35-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/world-of-warcraft-weekly-event-extra-honor-gains/>World of Warcraft Weekly Event, Extra Honor Gains</a></h3><div class=post__meta><time class="time published" datetime=2020-07-07T12:13:12+00:00 title="July 7, 2020 at 12:13 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/gta-6-development-status-and-release-date/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-768x768.jpeg 768w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-600x600.jpeg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe.jpeg 1004w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-768x768.jpeg 768w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-600x600.jpeg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe.jpeg 1004w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-768x768.jpeg 768w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe-600x600.jpeg 600w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/f73192305d41a02a9c1435010cf61dfe.jpeg 1004w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/gta-6-development-status-and-release-date/>GTA 6 Development Status and Release Date</a></h3><div class=post__meta><time class="time published" datetime=2020-07-07T12:02:36+00:00 title="July 7, 2020 at 12:02 pm"><i class="mdicon mdicon-schedule"></i>2 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/new-paper-mario-will-be-released-this-july-in-nintendo-switch/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/paper-mario-the-origami-king-switch-hero-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/new-paper-mario-will-be-released-this-july-in-nintendo-switch/>New ‘Paper Mario’ Will Be Released This July in Nintendo Switch</a></h3><div class=post__meta><time class="time published" datetime=2020-07-05T15:15:44+00:00 title="July 5, 2020 at 3:15 pm"><i class="mdicon mdicon-schedule"></i>4 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/pubg-mobile-update-0-19-0-leaks-ancient-secret-mode-boss-fight/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/tips-bermain-game-pubg-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/pubg-mobile-update-0-19-0-leaks-ancient-secret-mode-boss-fight/>‘PUBG Mobile’ Update 0.19.0 Leaks, Ancient Secret Mode Boss Fight</a></h3><div class=post__meta><time class="time published" datetime=2020-07-05T14:34:51+00:00 title="July 5, 2020 at 2:34 pm"><i class="mdicon mdicon-schedule"></i>4 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/huge-discount-for-gopro-hero-8-black/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images.jpeg 276w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images.jpeg 276w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/images.jpeg 276w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/huge-discount-for-gopro-hero-8-black/>Huge Discount for GoPro Hero 8 Black</a></h3><div class=post__meta><time class="time published" datetime=2020-07-05T14:12:12+00:00 title="July 5, 2020 at 2:12 pm"><i class="mdicon mdicon-schedule"></i>4 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/chinas-progress-to-become-world-leader-in-artificial-intelligence/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20190408_china_ai_3x2-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/chinas-progress-to-become-world-leader-in-artificial-intelligence/>China&#8217;s Progress to Become World Leader in Artificial Intelligence</a></h3><div class=post__meta><time class="time published" datetime=2020-07-05T13:57:29+00:00 title="July 5, 2020 at 1:57 pm"><i class="mdicon mdicon-schedule"></i>4 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/pixel-4a-release-date-google-discontinues-pixel-3a/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/051109800_1539131169-pixel-3-xl_edit-150x150.jpg 150w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/pixel-4a-release-date-google-discontinues-pixel-3a/>Pixel 4a Release Date, Google Discontinues Pixel 3a</a></h3><div class=post__meta><time class="time published" datetime=2020-07-05T12:58:33+00:00 title="July 5, 2020 at 12:58 pm"><i class="mdicon mdicon-schedule"></i>4 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/elon-musk-confirmed-tesla-semi-mass-production/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-400x400.jpg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/study-cites-tesla-semi-s-strengths-german-tech-expert-calls-it-pointless-600x600.jpg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/elon-musk-confirmed-tesla-semi-mass-production/>Elon Musk Confirmed Tesla Semi Mass Production</a></h3><div class=post__meta><time class="time published" datetime=2020-07-04T16:03:53+00:00 title="July 4, 2020 at 4:03 pm"><i class="mdicon mdicon-schedule"></i>5 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/airpods-with-ios-14-provides-a-new-level-of-experience/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2.jpeg 572w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2.jpeg 572w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-300x300.jpeg 300w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/mrxj2.jpeg 572w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/airpods-with-ios-14-provides-a-new-level-of-experience/>AirPods with iOS 14 Provides a New Level of Experience</a></h3><div class=post__meta><time class="time published" datetime=2020-07-04T15:48:11+00:00 title="July 4, 2020 at 3:48 pm"><i class="mdicon mdicon-schedule"></i>5 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/apples-iphone-se-plus-release-date-and-specs/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-600x600.jpeg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-180x180.jpeg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-600x600.jpeg 600w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-180x180.jpeg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-180x180.jpeg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-150x150.jpeg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-400x400.jpeg 400w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/iphone-se-red-select-2020_GEO_EMEA-600x600.jpeg 600w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/apples-iphone-se-plus-release-date-and-specs/>Apple&#8217;s iPhone SE Plus: Release Date and Specs</a></h3><div class=post__meta><time class="time published" datetime=2020-07-04T15:13:49+00:00 title="July 4, 2020 at 3:13 pm"><i class="mdicon mdicon-schedule"></i>5 days ago</time></div></div></article></li><li><article class="post post--horizontal post--horizontal-xxs"><div class="post__thumb ">
<a href=https://thegeekherald.com/p/playstations-5-detail-specs-and-leaked-price/><img width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-400x400.jpg 400w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif data-lazy-type=image data-src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-180x180.jpg class="lazy lazy-hidden attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset data-srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-400x400.jpg 400w" sizes="(max-width: 180px) 100vw, 180px"><noscript><img
width=180 height=180 src=https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-180x180.jpg class="attachment-tnm-xxs-1_1 size-tnm-xxs-1_1 wp-post-image" alt srcset="https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-180x180.jpg 180w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-150x150.jpg 150w, https://cdn.thegeekherald.com/wp-content/uploads/2020/07/20200703bb6592309fd0e06d2_th_1024x0-400x400.jpg 400w" sizes="(max-width: 180px) 100vw, 180px"></noscript></noscript></a></div><div class="post__text "><h3 class="post__title typescale-0"><a href=https://thegeekherald.com/p/playstations-5-detail-specs-and-leaked-price/>PlayStation&#8217;s 5 Detail Specs and Leaked Price</a></h3><div class=post__meta><time class="time published" datetime=2020-07-04T14:34:39+00:00 title="July 4, 2020 at 2:34 pm"><i class="mdicon mdicon-schedule"></i>5 days ago</time></div></div></article></li></ol></div></div></div></div></div></div></div></div><footer class="site-footer footer-1  "><div class="site-footer__section site-footer__section--seperated site-footer__section--bordered"><div class=container><nav class="footer-menu footer-menu--bold text-center"><div class=menu-footer-container><ul id=menu-footer class="navigation navigation--footer navigation--inline"><li id=menu-item-152 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152"><a href=https://thegeekherald.com/pg/dmca-policy-notice-and-takedown-procedure/>DMCA</a></li><li id=menu-item-153 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href=https://thegeekherald.com/pg/terms-and-conditions/>Terms and Conditions</a></li><li id=menu-item-154 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-154"><a href=https://thegeekherald.com/pg/privacy-policy/>Privacy Policy</a></li><li id=menu-item-443 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-443"><a href=https://thegeekherald.com/pg/about-us/>About Us</a></li><li id=menu-item-444 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href=https://thegeekherald.com/pg/disclaimer/>Disclaimer</a></li><li id=menu-item-445 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-445"><a href=https://thegeekherald.com/pg/contact-us/>Contact Us</a></li></ul></div></nav></div></div><div class=site-footer__section><div class=container><div class=text-center>
© Copyright 2019. TheGeekHerald.com. All Rights Reserved.</div></div></div></footer><div id=mnmd-sticky-header class="sticky-header js-sticky-header "><nav class="navigation-bar navigation-bar--fullwidth hidden-xs hidden-sm "><div class=navigation-bar__inner><div class=navigation-bar__section>
<a href=#mnmd-offcanvas-primary class="offcanvas-menu-toggle navigation-bar-btn js-mnmd-offcanvas-toggle">
<i class="mdicon mdicon-menu icon--2x"></i>
</a><div class="site-logo header-logo">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></div></div><div class="navigation-wrapper navigation-bar__section js-priority-nav"><div id=sticky-main-menu class=menu-main-menu-container><ul id=menu-main-menu-1 class="navigation navigation--main navigation--inline"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div><div class="navigation-bar__section lwa lwa-template-modal">
<button type=submit class="navigation-bar-btn js-search-dropdown-toggle"><i class="mdicon mdicon-search"></i></button></div></div></nav></div><div id=mnmd-offcanvas-primary class="mnmd-offcanvas js-mnmd-offcanvas js-perfect-scrollbar"><div class=mnmd-offcanvas__title><h2 class="site-logo">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></h2><ul class="social-list list-horizontal"></ul>
<a href=#mnmd-offcanvas-primary class="mnmd-offcanvas-close js-mnmd-offcanvas-close" aria-label=Close><span aria-hidden=true>&#10005;</span></a></div><div class="mnmd-offcanvas__section mnmd-offcanvas__section-navigation"><div id=offcanvas-menu-desktop class=menu-main-menu-container><ul id=menu-main-menu-2 class="navigation navigation--offcanvas"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div></div><div id=mnmd-offcanvas-mobile class="mnmd-offcanvas js-mnmd-offcanvas js-perfect-scrollbar"><div class=mnmd-offcanvas__title><h2 class="site-logo">
<a href=https://thegeekherald.com>
<img src=https://cdn.thegeekherald.com/wp-content/uploads/2019/03/Copy-of-The-Geek-Herald-1.png alt=logo>
</a></h2><ul class="social-list list-horizontal"></ul>
<a href=#mnmd-offcanvas-mobile class="mnmd-offcanvas-close js-mnmd-offcanvas-close" aria-label=Close><span aria-hidden=true>&#10005;</span></a></div><div class="mnmd-offcanvas__section mnmd-offcanvas__section-navigation"><div id=offcanvas-menu-mobile class=menu-main-menu-container><ul id=menu-main-menu-3 class="navigation navigation--offcanvas"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141 menu-item-cat-3"><a href=https://thegeekherald.com/p/category/news/>News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-142 menu-item-cat-4"><a href=https://thegeekherald.com/p/category/technology/>Technology</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143 menu-item-cat-5"><a href=https://thegeekherald.com/p/category/entertainment/>Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144 menu-item-cat-35"><a href=https://thegeekherald.com/p/category/automobiles/>Automobiles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145 menu-item-cat-27"><a href=https://thegeekherald.com/p/category/business/>Business</a></li></ul></div></div></div>
<a href=# class="mnmd-go-top btn btn-default hidden-xs js-go-top-el"><i class="mdicon mdicon-arrow_upward"></i></a></div> <script>var wpcf7 = {"apiSettings":{"root":"https:\/\/thegeekherald.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script>var ajax_buff = {"tnm_security":{"tnm_security_code":{"content":"a8f1414502"}}};</script> <script>var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};</script> <script>var a3_lazyload_extend_params = {"edgeY":"0","horizontal_container_classnames":""};</script> <script>if (typeof wpquads_adblocker_check === 'undefined') {
             wpquads_adblocker_check = false;
         } else {
             wpquads_adblocker_check = true;
         }</script> <script>if (typeof ga !== 'undefined' && wpquads_adblocker_check === false) {
          ga('send', 'event', 'Blocking Ads', 'true', {'nonInteraction': true});
      } else if (typeof _gaq !== 'undefined' && wpquads_adblocker_check === false) {
          _gaq.push(['_trackEvent', 'Blocking Ads', 'true', undefined, undefined, true]);
      }</script> <script defer src=//cdn.thegeekherald.com/wp-content/cache/autoptimize/js/autoptimize_a07ffd6b727d7153453d15c0f83c77fc.js></script></body></html>